Package Installation

 

Revised on October 8, 2020

 

 

Table of Contents

Required packages for using installer of the product

Required packages for installation of services only

Required packages for installation of the entire product

Installation of the required packages and drivers using the scripts in the product media

Required packages for using installer of the product

Before starting the installer of ActiveImage Protector, please make sure that the following packages are installed:
fuse.x86_64, gcc.x86_64, glibc.x86_64, libgcc.x86_64, libstdc++.x86_64, libuuid.x86_64, nss-softokn-freebl.x86_64, zlib.x86_64, make.x86_64, tar.x86_64, gzip.x86_64, unzip.x86_64, vim-common.x86_64, wget.x86_64, perl.x86_64, kernel-devel
*perl.x86_64 is required when setting up the product on Red Hat Enterprise Linux and CentOS 8 or later.
The following is an example of the installation procedures just for your reference. If you have any inquiry about the installation procedures, please contact your system administrator.

Use "yum" command to install the package

#yum install fuse.x86_64, gcc.x86_64, glibc.x86_64, libgcc.x86_64, libstdc++.x86_64, libuuid.x86_64, nss-softokn-freebl.x86_64, zlib.x86_64, make.x86_64, tar.x86_64, gzip.x86_64, unzip.x86_64, vim-common.x86_64, wget.x86_64, perl.x86_64

Run the following command to check the kernel version, and install kernel-devel of the same version.

#uname -r

Back to Table of Contents

Required packages for installation of services only

To install services only, please make sure that the following packages are installed:
glibc.x86_64, libgcc.x86_64, libstdc++.x86_64, libuuid.x86_64, nss-softokn-freebl.x86_64, zlib.x86_64, elfutils-libelf-devel.x86_64, libnsl.x86_64
*elfutils-libelf-devel.x86_64 and libnsl.x86_64 are required when setting up the services on Red Hat Enterprise Linux and CentOS 8 or later.

*The following is an example of the installation procedures just for your reference. If you have any inquiry about the installation procedures, please contact your system administrator.

Use "yum" command to install the package

#yum install glibc.x86_64 libgcc.x86_64 libstdc++.x86_64 libuuid.x86_64 nss-softokn-freebl.x86_64 zlib.x86_64 elfutils-libelf-devel.x86_64 libnsl.x86_64

Back to Table of Contents

Required packages for installation of the entire product

To install the entire product, please make sure that the following packages are installed:

glibc.x86_64, libgcc.x86_64, libstdc++.x86_64, libuuid.x86_64, nss-softokn-freebl.x86_64, zlib.x86_64, expat.x86_64, fontconfig.x86_64, freetype.x86_64, glib2.x86_64, libICE.x86_64, libSM.x86_64, libX11.x86_64, libXau.x86_64, libXext.x86_64, libXrender.x86_64, libxcb.x86_64, mesa-libGL.x86_64, systemd-libs.x86_64, elfutils-libelf-devel.x86_64, zlib-devel.x86_64, libnsl.x86_64
*systemd-libs.x86_64 is required when installing the product on Red Hat Enterprise Linux and CentOS 7 or later.
*elfutils-libelf-devel.x86_64 and zlib-devel.x86_64 and libnsl.x86_64 is required when installing the product on Red Hat Enterprise Linux and CentOS 8 or later.
The following is an example of the installation procedures just for your reference. If you have any inquiry about the installation procedures, please contact your system administrator.

Use "yum" command to install the package

#yum install glibc.x86_64 libgcc.x86_64 libstdc++.x86_64 libuuid.x86_64 nss-softokn-freebl.x86_64 zlib.x86_64 expat.x86_64 fontconfig.x86_64 freetype.x86_64 glib2.x86_64 libICE.x86_64 libSM.x86_64 libX11.x86_64 libXau.x86_64 libXext.x86_64 libXrender.x86_64 libxcb.x86_64 mesa-libGL.x86_64 systemd-libs.x86_64 elfutils-libelf-devel.x86_64 zlib-devel.x86_64 libnsl.x86_64

Run the following command to check the kernel version, and install kernel-devel of the same version.

#uname -r

Back to Table of Contents

Installation of the required packages and drivers using the script provided in the product's media

Before setting up ActiveImage Protector, please make sure the required packages are installed.
The use of this script enables to easily install the packages and drivers.

If your system is internet-connected, the required packages will be installed.
* Package installation via internet is not supported on Red Hat Enterprise Linux and CentOS 7.0 - 7.5.
If your system is not internet-connected, you need to use Linux OS set-up DVD.
The yum repositories are added from the Linux OS set-up DVD.
Then, the required packages will be installed from repositories in the Linux OS set-up DVD.
Note:
Because the required packages are included in Everything ISO on CentOS 7.x, you need to have Everything ISO.

How to use

  1. Login as root.
  1. Run the script [AIP-packages-tool.sh] included in the product media in the terminal.

# ./AIP-packages-tool.sh

Installation Menu includes the following items:
[1] Agent      Installation of required modules for using agents
[2] GUI      Installation of required modules for using GUI
[3] [1]-[2]All     Installation of agents and GUI module
[4] Kernel-devel     Installation of Kernel-devel
[5] Install datto driver     Installation of datto drivers
[6] Uninstall datto driver     Uninstallation of datto drivers
[7] help       Help
[8] exit      Exit



Back to Table of Contents

 

Back to Index